Announcement

Collapse
No announcement yet.

X position shifting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
  • X position shifting


    Hello
    . Actually got my machine exactly 1 year ago today. My whole goal getting the machine was to build Gun stocks. I’ve got a few models in fusion 360 that I’ve been making with my stinger 3 4x8, recoil, servo, x3, hsd, extra X travel built on gantry, laser engraver. I’ve upgraded to a 3 jaw chuck. The recoil has been anchored to the floor with brackets as seen in another post. A axis stepper power turned up with guidance from camaster. The tailstock was modified to align with chuck.
    Ok so most of the programs are about 8-12 steps with the same tool in spindle. I’m always having alignment issues about 50% of the time. Here is my machine setup procedure

    Turn on machine and computer

    initialize

    g49 g92

    install 1” precision ground drill rod in chuck and support with tail stock

    install .5” pointed drill rod in spindle (dummy bit)

    lathe home

    touch bit to top of 1” drill rod (use feeler gauge)

    move x to clear 1” rod. L91z-.5

    Calibrate switch

    lathe home

    touch bit to side of 1” rod (feeler gauge)

    raise Z

    L91 X.75 centers x

    Now I noticed the lathe home button over writes a x0y0 that I put in. I noticed when I crashed a $120 bit into the chuck.
    So now when I get this far in the procedure I will look at my win cnc and see how far off my x0 is from the one programmed in the lathe home button and I will go in and modify that macro (I think that’s what it’s called) to be exactly where I want my x0y0 to be. I was thinking fusion might be calling the lathe home macro between tool paths and moving my zero, so that’s why I was attempting to make them match.
    I’ve taken and cut all my step overs and step downs and cut them in half and increased speed to try and decrease the load on the machine. I’ve went from a 3.5 hour program to a 5 hour one. I was thinking I might be over powering the stepper on the A axis witch I thought was a servo. Everything on the machine seems tight. Spindle was trued with dial indicators. Tail stock and chuck side of drill rod received the same measurements.
    The other day when the program stopped I removed the bit and material and installed all my measurements rods while the machine was still on some my zeros should have been the same as lathe home. They werent. X was way off .027”. No dust collector was ran ever on any gun stocks.
    So my question is do you think it’s a fusion 360 programming issue, Or a machine issue. I’m using a post processor I found here. I’m really thinking the post processor is offsetting the tool paths but I’m at a complete loss.

  • #2

    You do not have permission to view this gallery.
    This gallery has 6 photos.

    Comment

    • #3

      If you're worried about the post processor, you should look at the g-code to see if it's doing anything with g92 commands to set X and Y. The lathe home button runs a macro to set lathe x and y. The name of the macro will be shown in the preview window. I suspect it'll probably be something like macros\lathe_home.mac. You should edit the G53 line it to send the head to correct position in the future, after doing your calibration. To see the g53 positions, you can either click the green boxes or use g92 to clear the green boxes. So you should never have to run your calibration steps again w.r.t. XY home positions for the lathe.

      It looks like you have a 3 head machine, so you probably won't be able to easily use the trick of a pseudo second switch to automatically have tool measures for the lathe be the correct height. One option may be to dedicate the rightmost router to the lathe. Or maybe just the main spindle and use the routers for flat CNC machining.
      Gary
      2018 Stinger II SR-44, 1.7kW Spindle, Performance Premium, Recoil, Gantry Lift, Cyclone
      Fusion 360
      Aspire

      Comment

      • #4

        Thanks Gary. I’ll check that out.

        Comment

        • #5

          Hopefully I found my problem. PCI board not fully connected. I will run a test stock tomorrow, wish me luck! I will say after I fully seated the pci board I ran the spindle warm up procedure. I noticed a unfamiliar sound, as I watched the win cnc screen I seen the spindle speed jump to the next speed in the process and I heard it for the first time change tone. I’ve apparently never had variable speed on my spindle. Now I’m hearing the differences in spindle speeds.
          You do not have permission to view this gallery.
          This gallery has 2 photos.

          Comment

          • #6

            Still working on my issue. Has anyone here ran into electric interference issues? Is everyone installing a separate ground rod just for the cnc? Is anyone running any type on line filters on there machines for preventative measures? Wish me luck!

            Comment

            • #7

              You can change the lathe home position in the drop down menu. Once you get that perfect, it should remain perfect as long as your machine is accurately touching off on the limit switches when you first start up. If you aren't getting a consistent home position, try slowing down the touch off procedure. Limit switches can be notoriously inaccurate if you go into them too fast.
              Russell Crawford
              Cobra 408 ATC with recoil
              Alberta, Canada
              www.cherryleaf-rustle.com

              Comment

              • #8

                Russel I have to change lathe home macro every time I turn the machine on. My x shift happens during a program, but not every time.

                Comment

                • #9

                  I’m sitting on a $32,000 paper weight

                  Comment

                  • #10

                    I would suggest redoing all the pci board items again. Pull them out, clean, reseat mother/daughter boards, all cables and each pin of the cables should be cleaned and checked.

                    Does this only happen with the rotary? Not on the table cutting?

                    Charlie L
                    Stinger II, 48 by 48, 1.7 kW Spindle, FTC + Laser + Recoil + Vacuum, July 2012
                    WinCNC 2.5.03, Aspire, PhotoVCarve, Windows 7 Pro SP1

                    Comment

                    • #11

                      Charlie I’ve only noticed the problem on the rotary. I dont really use the table, Ive only done a few signs with v carve pro on the table. I use fusion 360 for my cad and cam on the rotary. I’ve kinda ruled out the cam and post processor because of the erratic behavior, sometimes it’s good sometimes it bad.
                      Just had my electrical panel gone over by two separate electricians. I was worried my shop compressor was causing the issue so this weekend I just ran some more test with it on and off. I have a lathe in the shop that has a bonded common to ground so I disconnect that. My shop is in a complex of buildings so I did the test on the weekend to try and get the cleanest power to the shop.
                      Saturday
                      Test 1: compressor on, ghost run program off .010” at the end
                      Test 2: compressor off ghost run “perfect”
                      Sunday reverse order of Saturday
                      ​​​​​​ Test 3: compressor off “perfect”
                      Test 4: compressor on “perfect”
                      I’ve done multiple test similar to this by adding ground rods, spindle on and off. I’ve even ran the program for 5min stop it remeasure and it be off .006” already, then try to duplicate it and it perfect.
                      If I run 3 good test and go for it and try it on wood it’s almost always off.

                      Comment

                      • #12

                        As part of the ground rods, you've grounded the DC, right? And with a metal wire running inside the house that doesn't touch the machine but is grounded? I'm wondering if the head going lower for the recoil has something to do with it.
                        Gary
                        2018 Stinger II SR-44, 1.7kW Spindle, Performance Premium, Recoil, Gantry Lift, Cyclone
                        Fusion 360
                        Aspire

                        Comment

                        • #13

                          Any chance you are using a shop vac while cutting?
                          Gary Campbell
                          Servo Control Upgrades
                          GCnC411@gmail.com
                          https://www.youtube.com/user/Islaww1/videos

                          "There are 10 kinds of people in the world. Those that understand binary logic, and those who don't"

                          Comment

                          • #14

                            Gary, No shop vac or dust collection has been ran

                            Comment

                            • #15

                              Well tech support is non existent now. I hope these machines have a good resale value because this one will be up for sale soon. Total let down.
                              Biggest cash purchase of my life with years of saving and researching the perfect machine.
                              They simply don’t care once they get there money. Hopefully if Dave kindig of bitchen rides has a problem he gets help to fix it.

                              Comment

                              Working...
                              X